it-swarm-vi.tech

Tôi nhận được " PHP Thư viện Ngày/Giờ không được Máy chủ web của bạn hỗ trợ. "Trên Máy chủ CentOS của tôi, tôi cần cài đặt thư viện nào để thêm hỗ trợ?

Tôi đã nhanh chóng tìm kiếm xung quanh, nhưng các kỹ năng PHP của tôi còn khá mới. Tôi chắc chắn chỉ có một gói cần cài đặt.

Chỉnh sửa để thêm thông tin bổ sung về thiết lập:

Sử dụng:

yum info php

Tôi nhận phiên bản của PHP là 5.1.6:

Name       : php
Arch       : i386
Version    : 5.1.6

Thêm thông tin, đây là một VM đang chạy CentOS tại GoDaddy:

CentOS release 5.4 (Final)
1
Larry Smithmier

Nâng cấp lên PHP 5.2 trở lên

Thông báo lỗi bạn thấy là của WordPress. Về cơ bản, nó rất sai lệch khi nói rằng bạn cần một phiên bản PHP phiên bản> = 5.2 để tính năng đó hoạt động.

Vui lòng xem tài liệu hệ điều hành của bạn hoặc liên hệ với bộ phận hỗ trợ kỹ thuật về cách cập nhật phiên bản PHP của bạn. Ví dụ: đối với CentOS: CentOS HowTos: PHP 5.1 đến 5.2

Giữ các múi giờ được nâng cấp

Để tận dụng tối đa Hỗ trợ múi giờ PHP , có một gói PECL chứa tất cả các bản cập nhật mới nhất: timezencedb .

Vì vậy, bên cạnh việc nâng cấp PHP lên phiên bản gần đây, bạn có thể cài đặt gói PECL đó và cập nhật gói này để nhận các bản cập nhật múi giờ mới nhất (lần cuối là vào ngày 16 tháng 8):

$ yum install php-pear php-devel
$ pecl install timezonedb
3
hakre

wp-admin/options-general.php xuất thông báo lỗi sau:

Thật không may, bạn phải cập nhật thủ công này để tiết kiệm thời gian ban ngày. Thư viện PHP Ngày/Giờ không được Máy chủ web của bạn hỗ trợ.

Nó sẽ xuất ra khối mã đó nếu các hàm do PHP cung cấp bị thiếu:

Nhiều hàm trong số này được cung cấp bởi họ các lớp DateTime . Đây là một phần của PHP core kể từ phiên bản 5.1/5.2, tùy thuộc vào chức năng được đề cập. Mặc dù tôi ghét phải yêu cầu làm rõ trong một câu trả lời: Phiên bản nào của PHP Máy chủ của bạn đang chạy?

1
Annika Backstrom

Smithmier **:

UPDATE: Tôi thấy bản cập nhật của bạn không áp dụng cho bạn nhưng nó sẽ áp dụng cho nhiều người khác có cùng vấn đề của bạn và khi chúng tôi đang tìm câu trả lời chung cho câu hỏi áp dụng cho nhiều người hơn là tôi sẽ rời bỏ nó.


Tôi cho rằng @hakre đúng và nếu vậy nếu Máy chủ web của bạn cung cấp CPanel để bạn quản trị các bit kỹ thuật của tài khoản lưu trữ web đây là nơi bạn có thể thay đổi phiên bản PHP của mình:

Screenshot for PHP Configuration on CPanel
(nguồn: mikechinkel.com )

Sau đó sẽ đưa bạn đến màn hình này, nơi bạn có thể thay đổi phiên bản PHP của mình:

Changing your version of PHP on CPanel
(nguồn: mikechinkel.com )

1
MikeSchinkel